Pebble Tracker Not Registering / Showing Wallet Address / No Install Button on Firmware Upgrade Page

My pebble tracker keeps showing my wallet address.

I finally figured out how to get it into “Start OTA Firmware Update” mode but then it connects, says to start app from portal, I open the Firmware Upgrade app, and the instructions say there should be an install button. If there is, I do not see it. I tried pushing the power button on deice, clicking the View Website button, re-adding the device using add device button, and eventually, it just keeps going back to showing the wallet address.

I have to hold teh power button down for 8+ minutes for it to restart, which seems odd,.

I’m in the US. First I ordered the Autobahn SIM card, and now I am using the AT&T iot SIM card. Both doing the same thing.

I’ve tried removing the device from the portal but after selecting it and clicking remove device, nothing happens.

On the portal it says I have 1 connected device, not reporting any data.

Publish Frequency

Unknown

Last Publish Time

Unknown

Data Emits

Unknown

My Data tab says “:No Device Connected”

Any suggestions?

Hi Yoda,
can you please try following the step-by-step guide on pebble.iotex.io to register your device on the portal?

Yes, this is the one I have been using. Not sure if I need to download and configure the NRF Connect/firmware updates or if that was just with the older model.

The screen on the PT just keeps going to my iotex wallet address.

Also, I was thinking maybe it was some kind of partial setup/registration situation, and have tried removing the device but nothing happens when I click confirm.

When I re-add the device with a new name it boots out the old installation and replaces it with the new name so I take it that is not the issue.

The account is funded with 18 ioTex.

I am just unable to get the registration complete. I’m questioning if there is an issue with the device because it takes a super long time for it to restart when holding the button down (8-10 minutes) and seems to be non-responsive to any other button pushing.

Sometimes when I start it, it says NB-IOT Main-Net on bottom left of screen.
Other times it shows LTE.

I have yet to get it to say anything about registering. When I start it with the up button held down it starts in firmware update mode and asks me to select an app in the portal, and I cannot get it to go beyond that.

Right now when I start it, it connects to the mobile network with bars and a small M at the end of the bars. Then I have the ((-)) looking thing and the hot air balloon looking thing.

Then NB IOT Main-Net. And after a few minutes my ioTex wallet address comes up accoss the whole streen. The instructions say when that happens I should just push the power/confirm button on the device but that does not do anything.

There is a blue light slowly flashing, the network appears connected. Wallet address… and it’s unplugged from USB/charging port/fully charged.

Hi Yoda,
as per the quick start guide, you must perform two operations for the device registration:

  1. You propose it on the MachineFi portal by clicking “Add Device,” then input the device info, and finally confirm and sign the transaction in Metamask (make sure you have a few IOTX in Metamask, or you won’t be able to complete the transaction)
  2. Once step 1 is done, when you power on the device, it will first connect to the cellular network (could be NB-IoT or LTE), then it connects to the IoTeX network to check if there is any proposal pending and, if a proposal is found it will show your metamask address as a confirmation: I guess this is where you are. At this point, you need only to push and release the power button once to confirm that is your Metamask address**.** Please allow the device to complete the registration after you press the power button; it may take several minutes depending on the cellular signal strength in your area.

I appreciate your suggestion. Since I have already done that, how do I go about starting over? Maybe I just need to create a new wallet, transfer iotx there, reset the device and start over…

I have tried everything else, I will give that a go. Thank you

Edit - I misread what you said. I actually tried this several times. I just pushed it once and let it sit for hours. Pushed it again. Let it sit until the battery dies. When it comes back on I pushed it again when the wallet address comes up,. Not getting past it for some reason.

I just set up a new wallet, registered it there. Reset the device. And now I am in same situation, but my new wallet address is showing. We will see how it goes…

Update: I pushed the button 2 hours ago - wallet address still on screen. Still connected to mobile network.
Same situation as before.

Having this same issue, cannot figure it out.

1 Like

Still same. Auto-reply from Crowd Supply and replied to that but nothing yet.

I’ve now tried resetting and switching between SIM cards and accounts.

I thought it seemed promising at first but just a fakeout.