Swap fail Mimo

I’m trying to swap ioETH token for ioTX on my ioPay wallet but it will always say swap failed cannot complete transaction. I tried using walletconnect but once I input my ioPay private key it will say network error. I’ve been trying this swap for the past 3 days but it’s still not working. So after reviewing etherscan transaction for my smart contract from metamask I see there that my token was converted from ETH to WETH and not ioETH. I don’t have any idea why it end up ioETH on my ioPay wallet. Any idea? When I’m doing the swap mimo will just show my token balance in ioETH maybe because that’s the token on my ioPay wallet? How am I going to fix this? I missing out on the staking promo that starts today. Please help!

I’m having the same issue if anyone can help?


I ended up using changelly.

Thanks, did you get your ioETH tokens converted using Changelly on ioPay?

No that issue was resolved by creating another ioPay wallet. I used changelly to convert some of my xlm to iotx deposited to my newly created wallet because you need some iotx to move your ioETH from your old ioPay wallet to new ioPay wallet. From there I was able to swapped ioETH to ioTx.

You can swapped other coins to iotx via changelly just to get you started.

Thanks so much I owe you, got it fixed!!!

1 Like