Unable to Stake despite IoTeX Staking Guide (for Desktop Wallet)

Problem: While ioPay Desktop generally works well with the nano ledger, I am unable to stake although I was able to receive funds and transfer them to my ioPay IOTX wallet.

All in all, I was following the “IoTeX Staking Guide (for Desktop Wallet)” from Leo (from Aug 15th), but my progress never reached the part of "Choose the amount of IOTX you want to use for staking under … " due to the following problem:

Error description: Attempts towards either (i) staking or (ii) “vote NOW!” or (iii)“New Stake” via “https://member.iotex.io/my-votes” do not work, as I always get an error message saying “Error Please use ioPay desktop, import & unlock your wallet, and the refresh this page to continue.”

Attempts to solve the error: No amount of opening the IOTX application on the nano ledger, followed by opening ioPay Desktop, followed by navigating to “member iotex io” and then selecting any staking related option works in any way. I always get the same error (see above); also searching on google for that very error message has not yet yielded any success for me.

I have updated all systems involved:

  • Account: (on mainnet)
  • ioPay Desktop v1.0.12
  • NanoLedger App 0.1.7
  • Chrome 86.0.4240.183
  • Windows 10 (latest update)

I would be thankfull for any help

Or let me rephrase: Has anybody ever gotten the following combination to work for staking IoTeX:
Nano Ledger X + ioPay + Chrome on a Win 10 system?

If so, how?

From the lack of response I surmize that at the current state the IoTeX project does not yet allow for staking using a Nano Ledger X via ioPay on Chrome running on a windows 10 system.

Please let me know once that has changed and shoot me a direct message. Thank you

Am I correct to assume that staking via Nano Ledger X via ioPay on Chrome is neither possible nor being worked on at all?

Because I would like to encourage having a save and cold storage possibility for IoTeX. I am sure that having this option would drive adoption and induce an enve more serious flare for the entire project.

This may be an issue with old versions of ioPay desktop. Pls use the latest one (v1.0.15) and try again.

I’m having this same issue as well. I cannot stake from IoPay with my Ledger. I get the message “Error Please use ioPay desktop, import & unlock your wallet, and the refresh this page to continue.”

I’d love to figure this out so I can stake my tokens. It worked the other day when I was testing out the wallet then now longer works now that transferred my tokens to the wallet and Im ready to stake.

Much appreciated for your support in this.

I’m also getting same error, using latest version of ioPay desktop with Windows 11 (same issue was happening with Windows 10 before) and Chrome browser. This problem hasn’t been fixed! Please sort this out so we can stake.